Напишите программу,которая в последовательности натуральных чисел определяет количество нечетных чисел,кратных 5. Программа получает на вход количество чисел в последовательности,а затем сами числа. В последовательности всегда имеется число,кратное 4. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число -количество чисел, кратных 4
1)Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln(Введите a);
readln(a);
k1:=1;
k:=0;
While (a<>0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln(k=,k);
readln;
end. 2)
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln(Введите a);
readln(a);
k1:=1;
k:=0;
While (a<>0) and (k1<1000) do
Begin
if (a>0) and (a mod 2<>0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln(k=,k);
readln;
end.
Оцени ответ
