На языке Pascal написать программу
Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.
Задание выполнять с оператором while/
Помогите, пожалуйста

Program prog;
Uses Crt;

var n,a,x,k:integer;
begin
clrscr;

write(Введите число n = );
readln(n);
x:=n;

while (x>0) do begin
    a:=x mod 10;
    x:=x div 10;
    end;

while (n>0) do  begin
if  (n mod 10) = a then
k:=k+1;
n:=n div 10;
end;
writeln(Цифра ,a, встречается , k, раз(а));

end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку