Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).
Var
n,k:integer;
begin
Write(Укажите число и номер инвертируемого бита: );
Read(n,k);
Writeln(Результат: ,n xor (1 shl k))
end.
Тестовое решение:
Укажите число и номер инвертируемого бита: 573 4
Результат: 557
Оцени ответ
