Помогите пожалуйста с задачей) turbo pascal
составить программу к задаче :числа a,b и c называются "пифагоровой тройкой",если выполняется условие a*a+b*b=c*c отыщите все пифагоровы тройки среди чисел от 1 до n
Вот решение за O(n^3)
var
n,i,j,z:longint;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
for z:=1 to n do
if (i*i+j*j=z*z) then writeln(i, ,j, ,z);
end.
Оцени ответ
