Определите сумму всех элементов последовательности, завершающейся числом 0.
Числа, следующие за нулем, считывать не нужно.
Входные данные
Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
1
7
9
0
выходные данные
17

Pascal
 
var
    a,s : integer;
 begin
   s := 0;
   readln (a);
  While a <> 0 do
    begin
     s := s +a;
     readln (a);
    end;
 
  writeln (s);
 end.




Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку