Известно,что Дима купил 12 воздушных шариков за 12 рублей. Среди купленных шаров были шары желтого,красного и зеленого цветов. Какое количество желтых,красных и зеленых шаров было куплено Димой,если желтый шар стоит полрубля,красный полтора рубля, а зеленый два рубля?
В ответе укажите количество желтых,красных и зеленых шаров соответственно,записав в поле ответа только числа через один пробел без каких-либо знаков препинаний,например, 9 4 2
Желтые Красные Зеленые
6 6 0
8 0 4
7 3 2
Вот программка на Паскале:
uses Crt;
var g, k, z:integer;
begin
ClrScr;
for g:=0 to 12 do
for k:=0 to 12 do
for z:=0 to 12 do
begin
if (g+k+z=12) and (0.5*g+1.5*k+2*z=12) then
WriteLn (g, ,k, , z);
end;
ReadLn;
end.
Вывод: Можно вообще не брать красные или зеленые шары.
Если брать шары всех цветов, то ответ у задачи один
7 3 2
Оцени ответ
