Дано действительное число Х. Напишите программу для вычисления:
Числа Х, округлённого до ближайшего целого
Числа Х без дробных цифр
В Паскале есть функция Round, которая использует следующий "стандартный" алгоритм округления:
Если число положительное, то при величине его дробной части меньше 0.5, она просто отбрасывается, если больше - отбрасывается и к числу прибавляется единица. Если число отрицательное, то при абсолютной величине его дробной части меньше 0.5, она просто отбрасывается, если больше - из числа вычитается единица.
А функция Trunc возвращает целую часть числа.
var
p:real;
begin
Write(Введите число: ); Read(p);
Writeln(Округленное значение: ,Round(p),, целая часть: ,Trunc(p))
end.
Тестовое решение:
Введите число: -12.74
Округленное значение: -13, целая часть: -12
Введите число: 12.93
Округленное значение: 13, целая часть: 12
Введите число: 9.4323
Округленное значение: 9, целая часть: 9
