Дан двухмерный массив "у" с размерностью n x m если все элементы строки четные, то вывести порядковый номер строки.
в паскале
написать программу

Var
  y:array[1..999, 1..999] of integer;
  i, j, n, m:integer;
  chet:boolean;

begin
  randomize;
  readln(n, m);
  //Рандомно заполняем и выводим двумерный массив числами от 0 до 100
  for i:=1 to n do
  begin
    for j:=1 to m do begin
      y[i, j]:=random(101);
      write(y[i, j], );
    end;
    writeln;
  end;
  writeln;
  for i:=1 to n do
  begin
    chet:=true;
    for j:=1 to m do
      if y[i, j] mod 2 <> 0 then
        chet:=false;
    if chet = true then
      write(i, );
  end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку