Требовалось написать программу вычисления факториала числа n(n!=1*2*..*n). Программист торопился и написал программу неправильно. Ниже приведен фрагмент его программы, в которой содержится 5 ошибок:
K:=1;
F:=0;
While k
F:=f*k;
K:=k+1;
Найдите ошибки. Допишите необходимые операторы и выполните программу на компьютере. (Проверка 5!=120, 6!=720).

Язык С++:
#include
using namespace std;
void main(){
int n=5, k, f=1; //f - факториал, n - число, фак-ал которого нужно вычислить
while(k<=n){
f*=k;
k++;
}
cout<<"Факториал числа "<}
Pascal:
program z4;
var n, k, f: integer;
begin
write(Введите число, для которого нужно вычислить факториал : );
readln(n);
k:=1;
f:=1;
while(k<=n)
begin
f:=f*k;
k:=k+1;
end;
writeln(Факториал равен : , f);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку