Вариант А
1) Опишите, что выполняет данная программа. Приведите пример на конкретных числах:
var a,b,s,j:integer;
begin
read(a,b);
s:=0;
for j:=a to b do
begin
s:=s+j;
end;
write(s);
end.
2) Напишите программу, которая выводит все четные числа до заданного пользователем числа.

1) Программа находит сумму всех чисел от a до b. Например для 3 и 5, она выведет 12

2)
var
    a, i:integer;
begin
    read(a);
    for i := 1 to a do
        if i mod 2 = 0 then
            write(i, );
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку