В паскале написать программу:
Вывести среднее арифметическое двузначных четных чисел
Const
n=20;
var
a:array[1..n]of integer;
i,k:integer;
s:real;
begin
for i:=1 to n do
begin
a[i]:=random(201)-100;
write(a[i]:4);
if (a[i]>=10)and(a[i]<100)and(a[i]mod 2=0)then
begin
s:=s+a[i];
k:=k+1;
end;
end;writeln;
if k<>0 then
writeln(s/k:4:2)
else
writeln(нет четных двузначных);
end.
Оцени ответ
