Помогите составить программу на паскале Вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. Определить число членов суммы. Значение суммы и число ее членов вывести на экран с соответствующими комментариями.

Вроде получилось:

var a,b,s:integer; 
begin
write(Числа = );
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,, );
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln(Сумма чисел = , s);
end.

Результат:

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку