Винни Пух по поводу своего Дня рождения решил угостить своих друзей: Кролика, Пяточка, Сову и ослика Иа. В магазине он купил полкило замечательных шоколадных конфет. Но, по дороге домой, Винни останавливался три раза, и каждый раз съедал половину всех имеющихся у него конфет и еще полконфеты. Причем известно, что на каждой остановке Винни съедал целое количество конфет. Сколько конфет купил Винни Пух, если каждому его другу досталось только по одной конфете?
Для решения задачи можно использовать любую среду программирования. В ответе укажите только число без каких-либо знаков препинания, например 48
// среда программирования PascalABC
var i,x :byte;
begin
x:=4; // Так как у Вини 4 друга
for i:=3 downto 1 do // цикл с обратным отсчетом
begin
x:=x+x+1;
writeln (до ,i, остановки у Вини было конфет ,x); // за не надобностью эту строку можно удалить
end;
writeln (x);
end.
Оцени ответ
