1)Составьте программу, которая выводит на экран таблицу перевода а, а+1,а+2,...б минут в секунды. Границы а и б вводятся с клавиатуры.
Введите границы :12 18
12 мин = 720 сек........... 18 мин =1080 сек
2)Составить программу для решения следующей задачи: Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за N дней?
( все в Паскале)

1.

program xopow1;
   uses  crt;
   var 
 a, b, Sek: integer; 
begin 
writeln(Введите границы:); 
repeat   
readln(a, b); 
until b >= a; 
 clrscr; 
for a := a to b do
    begin   
Sek := a * 60;   
writeln(a, мин. = , sek, сек.) 
end
end.



2.

program xopow2;
  uses crt; 
Var
 z:integer;
 f,x,y:real; 
Begin 
clrscr; 
Writeln;
X:=10000;
Y:=(x/100)*10;
for z:=1 to 7 do 
 Begin 
X:=x+y; 
Writeln(Z, -й день тренировок спортсмен пробежал ,X:3:2, Км.); 
End; 
Writeln(Нажмите Enter...); 
Readln; 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку