Написать программу.
Паскаль
Первый знак - это большая греческая (чуть не написал свадьба :)) буква Сигма, что значит Сумма элементов по переменной b от 3 до N с шагом ∆b.
Она применяется, если d <= 0
Второй знак -это большая греческая буква Пи, что значит Произведение
элементов по переменной с от 2 до 9.
Она применяется, если d > 0
var a, b, c, d, db, N, L: real
writeln(Vvedite a, d, db, N : );
readln ( a, d, db, N );
if (d <= 0) then
begin
L := 0; b := 3;
while b <= N do
begin
L := L + b - a*d;
b := b + db;
end;
end;
else
begin
L := 1;
for c := 2 to 9 do L := L*(pow(c, a) + tan(d));
end;
writeln (L);
end.
Оцени ответ
