Написать программу в Pascal
числа a,b и c вводятся с клавиатуры.найти max(a,a+b)+max(a,b+c)/1+max(a+b*c,1,5)

Уверен, что формула в условии написана неверно, но уж как написано...

var
  a,b,c:real;
begin
  Write(Введите a,b,c: ); Read(a,b,c);
  Writeln(Результат: ,max(a,a+b)+max(a,b+c)/1+max(max(a+b*c,1),5))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 31

А вот так, на мой взгляд, должно быть:
var
  a,b,c:real;
begin
  Write(Введите a,b,c: ); Read(a,b,c);
  Writeln(Результат: ,(max(a,a+b)+max(a,b+c))/(1+max(a+b*c,1.5)))
end.

Тестовое решение:
Введите a,b,c: -3 5.5 4
Результат: 0.6

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку