написать программу позволяющую по последней цифре числа определить последнюю цифру его квадрата
все просто, что бы определить какой цифрой закончится число, надо взять последнюю цифру этого числа и возвести ее в квадрат. Затем, если число двузначное, то ответом будет послденяя цифра поученного числа или если число однозначное, то оно и будет ответом.
var a:integer;
begin
read(a);
write(sqr(a) mod 10);
end.
Оцени ответ
