Написать программу для Паскаля. Даны координаты вершин треугольника АВС. Найти его площадь.
program Triangle;
var X1,X2,X3,Y1,Y2,Y3: real;
p, a, b, c: real;
begin
Writeln(Введите координаты точек (X1,Y1), (X2,Y2), (X3,Y3):);
ReadLn(X1, Y1, X2, Y2, X3, Y3);
a: = Dlina(X1-X2,Y1-Y2);
b := Dlina(X1-X3,Y1-Y3);
c := Dlina(X2-X3,Y2-Y3);
p := (a+b+c)/2;
WriteLn(Площадь равна , sqrt(p*(p-a)*(p-b)*(p-c)));
end;
fucntion Dlina(var x,y:real):real;
begin
Dlina := sqrt(x*x+y*y);
end.
Оцени ответ
