написать программу для pascal: выиснить является ли заданное число совершенным?
Program Pr1;
uses crt;
var i,n,a:integer;
Begin
clrscr;
readln(n);
i:=1; a:=0;
while i<=n do begin
if (n mod i=0) and (i<>n) then a:=a+i;
inc(i);
end;
if a=n then writeln(YES)
else writeln(No);
end.
Оцени ответ
