Сколько четырехзначных чисел, у которых сумма первой и третьей цифр равны сумме второй и четвертой. Напишите программу, которая позволит вывести все такие числа.
в паскале

Var a,b,c,d,e:integer;
begin
for a:=1000 to 9999 do begin
e:=a;
b:= e mod 10;
e:= e div 10;  
c:= e mod 10;
e:= e div 10;  
d:= e mod 10;
e:= e div 10;   
if (b+d)=(c+e) then writeln(a);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку