Помогите пожалуйста очень срочно нужно написать программу в Паскаль. Группу детей, приехавшую в оздоровительный лагерь, распределяют по отрядам по принципу: с 6 до 7 лет — 5-й отряд; с 8 до 9 лет — 4-й отряд; с 10 до 11 лет — 3-й отряд; с 12 до 13 лет — 2-й отряд; с 14 до 15 лет — 1-й отряд. Составить программу, которая позволила бы каждому ребенку определять свой отряд.

{1 вариант}
var otr, vozr: byte;
begin
  writeln(введите возраст);
  readln(vozr);
  case vozr do
  6,7: otr:=5;
  8,9: otr:=4;
  10,11: otr:=3;
  12,13: otr:=2;
   14,15: otr:=1;
  end;
 writeln(Ваш отряд, otr);
end.

{2 вариант - более простой}
var otr, vozr: byte;
begin
  writeln(введите возраст);
  readln(vozr);
  otr:=5 - vozr div 2 + 3;
  writeln(ваш отряд, otr)
end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку