Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот период. Прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0).
На входе программа получает период N

через генератор случайных чисел
program noname;
uses crt;
var
n,k,i:integer;
a:array[1..1000] of longint;
max:longint;
begin
clrscr;
write(vvedi period n=);
readln(n); k:=0;
for i:=1 to n do begin
randomize;
a[i]:=random(10000);
writeln(a[i]);
if a[i]-1000<0 then k:=k+1;
end;
max:=a[1];
for i:=2 to n do
if maxwriteln(k,-дни без прибыли ,max,-максимальная выручка);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку