Быстрее, пожайлуста!!! Очень важно!!!
2) Составить программу, которая в целом двумерном массиве (6,3) определяет число элементов больше числа, которое вводится с клавиатуры. Массив сгенерирован с помощью датчика случайных чисел в диапазоне (1,8). Элементы массива вывести на экран построчно

Var c: array [1..6, 1..3] of integer;
     k,n,m,i,j,b: integer;
     find:boolean;
begin
  writeln(введите число);
  readln (b);
  randomize;
  n:=6;m:=3;
  k:=0;
  for i:=1 to n do
  begin
  for j:=1 to m do
   begin
     c[i,j]:=2+random(6);   {не включая 1 и 8}
     if (c[i,j]>b) then k:=k+1;
     write(c[i,j]:6);
   end;
  writeln;
  end;
  writeln(число элементов , k:7)
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку