Разработать схему алгоритма, который вводит массив из n целых чисел и выводит номера отрицательных элементов и сами эти элементы. Протестировать алгоритм для следующих массивов:
а) 3 5 -2 3 -2 0 -6 -8 1
б) -1 -2 -3 -4 0 -1 2 3
Написать программу на языке Паскаль.
Const
nn = 50;
var
a,b,nb:array[1..nn] of integer;
i,n,j: integer;
begin
Write(Введите количество элементов в массиве (n<51): );
Read(n);
Writeln(Вводите элементы массива);
j:=0;
for i:=1 to n do
begin
Read(a[i]);
if a[i]<0 then begin Inc(j); b[j]:=a[i]; nb[j]:=i end
end;
if j>0 then begin
Write(Отрицательные элементы: );
for i:=1 to j do Write(b[i], );
Writeln;
Write(Индексы отрицательных элементов в массиве:);
for i:=1 to j do Write(nb[i]:3);
Writeln
end
end.
Результаты тестирования:
Введите количество элементов в массиве (n<51): 9
Вводите элементы массива
3 5 -2 3 -2 0 -6 -8 1
Отрицательные элементы: -2 -2 -6 -8
Индексы отрицательных элементов в массиве: 3 5 7 8
Введите количество элементов в массиве (n<51): 8
Вводите элементы массива
-1 -2 -3 -4 0 -1 2 3
Отрицательные элементы: -1 -2 -3 -4 -1
Индексы отрицательных элементов в массиве: 1 2 3 4 6
