ПОМОГИ ПОЖАЛУЙСТА!!!! Вкладчик внес в сберкассу x рублей. Написать программу,вычисляющую,сколько денег будет у него через n лет. Кол-во денег каждый год увеличивается на 3 % по отношению к предыдущему году.

program test;
var years: integer; contribution: real;
begin
   write(Enter the contribution sum: );
   readln(contribution);
   write(Enter the number of years: );
   readln(years);

   while years <> 0 do
   begin
      contribution:=contribution+(contribution / 100 * 3);
      years:=years-1;
   end;

   writeln(contribution:0:2, rub);

   readln;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×