Очень срочно пожалуйста
Напишите программу которая находит среднее арифметическое всех чисел записанных в файле в столбик и выводит результат в другой файл
Var
n,d,s:longint;
mid:real;
f:Text;
begin
n:=0; s:=0;
Assign(f,input.txt); Reset(f);
while not Eof(f) do begin
Readln(f,d);
if not Eof(f) then begin Inc(n); s:=s+d end
end;
Close(f);
Assign(f,output.txt); Rewrite(f);
mid:=s/n;
Writeln(f,mid);
Close(f);
end.
Оцени ответ
