5. В двухмерном массиве хранится информация о количестве студентов в той или иной группе каждого курса инсти¬тута с первого по пятый (в первой строке — информация о группах первого курса, во второй — второго и т. д.). На каж¬дом курсе имеется 8 групп. Составить программу для расчета общего числа студентов на любом курсе.
СИ ШАРП.

Using System;

namespace Znanija {
    internal class Program {

        private static void Main() {
            var r = new Random(DateTime.Now.Millisecond);
            var course = r.Next(1, 6);
            var students = new int[5,8];

            for (var i = 0; i < students.GetLength(0); i++) {
                for (var j = 0; j < students.GetLength(1); j++) {
                    students[i, j] = r.Next(10, 40);
                    Console.Write("{0:d2} ", students[i, j]);
                }
                Console.WriteLine();
            }

            Console.WriteLine("На курсе {0} кол-во студентов = {1}", course, CountStudents(students, course));
            Console.ReadKey();
        }

        private static int CountStudents(int[,] students, int course) {
            if (students.GetLength(0) < course) {
                Console.ForegroundColor = ConsoleColor.Red;
                Console.WriteLine("Нет курса " + course);
                return 0;
            }

            var number = 0;
            for (var i = 0; i < students.GetLength(0); i++) {
                number += students[course - 1, i];
            }

            return number;
        }

    }
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку