Гарри Поттер узнал, в Хогвартсе номера комнат преподавателей делятся без остатка на все свои цифры, в остальных же комнатах живут ученики. Помогите Гарри определить по известному номеру комнаты N (1 Формат входных данных:
Исходный файл содержит одно число N (1 Формат выходных данных:
В выходной файл вывести, букву «T», если в комнате живет учитель (число N делятся без остатка на все свои цифры кроме нуля) или «P» если ученик (число N не делятся без остатка хотя бы на одну из цифр).

//Это можно стереть. Если в N есть 0 то тогда программа выведет NO.
program z1;
var b,c,d,i,s,l:integer;   
a:string;
begin
read(a);
b:=length(a);
s:=StrToInt(a);
c:=0;
for i:=1 to b do 
for i:=1 to b do 
begin 
d:=StrToInt(a[i]); 
if d=0 then l:=1; 
end;
if l=0 then begin                 
for i:=1 to b do                     
for i:=1 to b do                     
begin                     
d:=StrToInt(a[i]);                     
if (s mod d)=0 then c:=c+1;                     
end;           
end           
else           
write(NO);if (l=0) and (c=b) then write(T);
if (l=0) and (c<>b) then write(P);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×