СРОЧНО!!! Составить программу на языке Паскаль.
Найдите среднее ариыметическое натуральных чисел от 1 до n кратных 5.

Program z1;
var a:array[1..10000] of longint;   
      k,i,s,r:longint;   
      v:real;
begin
read(k);
for i:=1 to k do
read(a[i]);
s:=1;
r:=0;
v:=0;
for i:=1 to k do
if (a[i] mod 5)=0 then begin                       
                               s:=s*a[i];                       
                               r:=r+1;                       
                               end;
v:=s/r;
write(v);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку