(Паскаль или Delphi)
Написать программу поиска двухзначных чисел, удовлетворяющих следующему условию: если к сумме цифр числа прибавить квадрат этой суммы, то получится само
число.
Program z_3;
var a,b,n,s, i: integer;
Begin
repeat
writeln (Введите Ваше число);
readln (n);
if (n < 10) or (n > 99) then i:= 0
else i:= 1;
until i>0;
a:= n mod 100 div 10;
b:= n mod 10;
s:= (a+b)+sqr (a+b);
if s <> n then writeln (Число не соотвествует условию)
else writeln (Число ,s, соответствует условию);
End.
Оцени ответ
