Существуют тройки Пифагора, то есть a^2+b^2=c^2 . Есть лишь одна такая тройка, что
a+b+c=1000 . Написать программу, которая находит эту тройку(a=?, b=?, c=?) и выводит ее.
Var
i,j,k:longint;
begin
for i:=1 to 1000 do
for j:=1 to 1000 do
for k:=1 to 10000 do
if sqr(i)+sqr(j)=sqr(K)then
begin
writeln(i, ,j, ,k); {вывожу все тройки, можно убрать}
if i+j+k=1000 then
begin
writeln(! ,i, ,j, ,k); {нужная тройка}
exit; {прерывание программы}
end;
end;
end.
