10 Класс
Напишите программу обработки последовательности целых чисел.
На вход программе сначала подается натуральное число N - кол-во элементов последовательности, N не превосходит 1000. Затем следуют натуральные числа, каждое число в отдельной строке. Каждый элемент последовательности не превосходит 10000.
Программа должна выводить все элементы последовательности, являющиеся трехзначными числами, кратными семи, в порядке, обратном порядке ввода. Если таковых нет, программа выводит число -1
Заранее спасибо!
Program primer;
Var a:array[1..1000] of integer;
i,m,k,n: integer;
Begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=n downto 1 do begin //в обратном порядке
k:=0;
m:=a[i];
while m>0 do begin
m:=m div 10;
inc(k); // ищем количество разрядов
end;
if ((a[i] mod 7) =0) and (k=3) then write(a[i]:2);//кратно 7 и 3 разряда - выводим
end;
end.
ABC Pascal
Оцени ответ
