PascalABC
Составьте программу для вычисления значения силы тока I на участке, состоящем из двух параллельно соединенных резисторов сопротивлением R1 и R2, если
напряжение на концах этого участка равно U.
//Общее сопротивление сети:
// 1/R = 1/r1 + 1/r2
// 1/R = (r2+r1)/(r2*r1)
// R = r2*r1 / (r2 + r1)
//Закон Ома для участка цепи:
// I = U/R
var
r1,r2,u : integer;
R,I : real;
begin
writeln (Введите значения сопротивления (r1 r2));
readln (r1,r2);
writeln (Укажите напряжение на концах цепи (u));
readln (u);
R := r2*r1 / (r2 + r1);
I := U/R;
//Фактически можно не использовать переменную R
//А вставить выражение сразу
// I := U/( r2*r1 / (r2 + r1) );
writeln (Сила тока на участке = ,I);
end.
Оцени ответ
