Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. Пакетов может быть неограниченное количество. Сколько гречи будет в последнем заполненном пакете?
Помогите, пожалуйста.

// Написать программу: Гречу, массой х г, рассыпают по пакетам: по а г в каждый. 
//Пакетов может быть неограниченное количество. Сколько гречи будет в
//последнем заполненном пакете?

var x,a  : longword;
begin
  writeln (Введите общую массу гречи, в граммах);
  readln (x);
  writeln (Введите массу насыпаемой в пакет гречи, в граммах);
  readln (a);
  writeln (полных пакетов будет ,(x div a));
  if (x mod a)=0  then writeln (В последнем насыпанном пакете будет ,a, грамм гречи)
                  else writeln (В последнем насыпанном пакете будет ,(x mod a), грамм гречи);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку