Составить программу сокращения одномерного числового массива путем удаления а) всех элементов с нулевыми значениями Дополнительный массив использовать не разрешается!!! Помогите, а то запара!!!!!!!!!!!Спасибо!!!!!!!!!!!!!!
var
a : array [1..100] of integer;
i, next, n : integer;
begin
read (n);
for i := 1 to n do read (a[i]);
next := 1;
for i := 1 to n do
if a[i] <> 0 then
begin
a[next] := a[i];
next := next + 1;
end;
n := next - 1;
for i := 1 to n do
write (a[i], );
end.
В результате работы в N будет лежать новая длина, а после массива - будет лежать всяий мусор (огрызок прежднего массива), но это неважно.
Оцени ответ
