Помогите срочно Решить задачи по информатике
1. Найти значение выражения у=6+х/3-а - это типа дробь с числителем и знаменателем
2. С клавиатуры вводятся несколько чисел, найти кол-во кратных 3 и сумму не кратных 3
Надо программу на английском составить, ну там begin, write и.т.д

Var
  a,x:real;
begin
  Write(Введите через пробел x и a: );
  Read(x,a);
  Writeln((6+x)/(3-a))
end.
 
Результат выполнения программы:
Введите через пробел x и a: 5.18 4.65
-6.77575757575757

var
  i,d,n,k,s:integer;
begin
  Write(Укажите количество чисел: ); Read(n);
  Writeln(Вводите числа: );
  k:=0; s:=0;
  for i:=1 to n do
  begin
    Read(d);
    if (d mod 3)=0 then Inc(k)
    else s:=s+d
  end;
  Writeln(Количество кратных 3 равно ,k);
  Writeln(Сумма некратных 3 равна ,s)
end.

Тестовое решение:
Укажите количество чисел: 7
Вводите числа:
4 18 6 45 7 20 8
Количество кратных 3 равно 3
Сумма некратных 3 равна 39

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку