Написать программу: На концерте было K зрителя. Из них K1 человек купили билеты по c1 рублей, а остальные-по с2 рублей. Сколько денег (SUM) было выручено от продажи билетов? (К=894 чел., К1=396 чел., с1=150 рублей, с2=200 рублей) _____________________________________________ объясните принцип действия оператора sum, не был на уроке, а ничего дельного не нашел

Тут и обяснять особо нечего. Сначала вычесляем сколько было "остальных" зрителей, потом общую сумму от продажи k1 человекам, потом общую сумму от продажи k2(остальным) человекам, то и то складываем и присваиваем переменной sum.

program test;
var k, k1, k2, c1, c2, sum: integer;
begin
   k:=894;
   k1:=396;
   c1:=150;
   c2:=200;
   k2:=k-k1;
   sum:=k1*c1 + k2*c2;
   writeln(Sum = , sum, rub);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку