Составить программу вычисления суммы мест, на которых в строке, введенной с клавиатуры, стоят согласные буквы. Например в строке сумма мест согласных букв равняется 1+2+3+5+=11

Var 
s,g:string;
sum:integer;
begin
g:=бвгджзйклмнпрстфхцчшщБВГДЖЗЙКЛМНПРСТФХЦЧШЩ;
read(s);
sum:=0;
for var i:=1 to length(s) do
if (pos(s[i],g)>0) then sum:= sum+i; 
writeln(sum);
end.
//ABC Pascal

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку