Написать программу , которая позволяет найти нужные сведения в телефонном справочнике dphone.txt программа должна запрашивать фамилию человека и выводить его в телефон. Если в справочнике есть одинаковые фамилии, то программа должна ввести список всех людей, имеющих эти фамилии.
PascalABC.Net
const
//Формат файла
//Фамилия имя номер
fl = D:phone.txt;
var
t : text;
c : char;
Fnm,s : string;
begin
assign (t,fl);
reset (t);
writeln (Укажите фамилию);
readln (Fnm); writeln();
While not eof (t) do
begin
s := ;
//Считываем фамилию
read (t,c);
While c <> do
begin
s := s + c;
read (t,c);
end;
//Если Фамилию нужная то дочитываем
//иначе переходим к следующему
if s = fnm then
begin
write (s+ );
While not eoln(t) do
begin
read (t,c);
write (c);
end;
readln (t);
writeln ();
end
else
readln (t);
end;
close (t);
end.
Оцени ответ
