Составить программу на паскаль:
Рассчитать радиус окружности, вписанной в треугольник R1= S/p
и описанной вокруг треугольника R2= a*b*c/(4*S), где S - площадь, а p - полупериметр треугольника. a, b, c - стороны треугольника ( исходные данные ).
Находим периметр p=a+b+c, затем полупериметр , и далее по формуле Герона площадь S.
var
a,b,c,p,s,p2,r1,r2:real;
begin
Write(Введите стороны треугольника: );
Read(a,b,c);
p:=a+b+c; p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
r1:=s/p; r2:=a*b*c/(4*s);
Writeln(R1=,r1,, R2=,r2)
end.
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684
Оцени ответ
