Составить программу для вычисления суммы натуральных чисел которые делятся нацело на 7 для массива от 1 до 100

Program mew;
var a: array [1..100] of integer;
sum,i: integer;
begin
sum:=0;
for i:=1 to 100 do
begin
a[i]:=random(100);
if (a[i] <> 0) and (a[i] mod 7 = 0)  then
begin
write(a[i], );
sum:=sum+a[i];
end;
end;
writeln(Сумма равна, , sum);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку