Ребят,помогите,ничего вообще не понимаю...((Что вообще за модуль,содержащий процедуру..нужно написать программу)если можно с объяснениями)
Написать модуль,содержащий процедуру нахождения минимальной цифры натурального числа. Привести пример использования данного модуля.(в Паскале)

Текст модуля (Free Pascal):
unit MyLib;
interface
  procedure MinDigit(n:longint;var md:byte);
implementation
  procedure MinDigit(n:longint;var md:byte);
  var
    d:byte;
  begin
    md:=10;
    while n>0 do begin
      d:=n mod 10;
      if d      n:=n div 10
    end
  end;
begin
end.

Тестовая программа:
uses
  Crt, MyLib;
var
  p:byte;
begin
  ClrScr;
  MinDigit(45134,p);
  Writeln(p=,p);
  ReadKey
end.

Тестовое решение:
p=1

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку