Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC
Program eX_1;
var s: String;
n, i, b, j: longint;
c: char;
begin
writeln(Введи текст из сообщения выше:);
readln(s);
for i:=length(s) downto 1 do
if s[i] in [a..z] then s[i]:=Upcase(s[i])
else if s[i] in [A..Z] then s[i]:=chr(ord(s[i])+32)
else if s[i] in [0..9] then delete(s,i,1);
write(s);
end.
Program eX_1;
var s: String;n, i, b, j: longint;c: char;
begin
writeln(Введи текст из сообщения выше:);
readln(s);for i:=length(s) downto 1 do
if s[i] in [b..z] then s[i]:=chr(ord(s[i])-1)
else if s[i]=athen s[i]:=z ;
write(s);
end.
Оцени ответ
