В программе обрабатывается одномерный целочисленный массив А с индексами от 0 до 9. Значения элементов равны 8;5;11;4;6;9;4;10;7;8 соответственно, т.е. A[0]=8;a[1]=5 и т.д.
Определите значение переменной s после выполнения следующего фрагмента программы, записанного ниже на Паскале
k:=0; t:=0;
for i:=0 to 9 do
if A[i]>k then begin
t:=k;
k:=A[i]
end
else
t:=A[i];
S:=k+t;
Const
A: array of integer=(8, 5, 11, 4, 6, 9, 4, 10, 7, 8);
var
k, t, i, S: integer;
begin
k:=0; t:=0;
for i:=0 to 9 do
if A[i]>k then begin
t:=k;
k:=A[i]
end
else
t:=A[i];
S:=k+t;
writeln(S);
end.
Ответ: 19
Оцени ответ
