Написать программу Вводя числа с клавиатуры без ограничения их количества (конец ввода - число 0), найти сумму положительных и произведение отрицательных чисел .СРОЧНО.

program c1;
var
a,b,n:longint;
Begin
a:=0;
writeln(Вводи числа sergei1906);

repeat
read(n);
if n>0 then b:=b+n;
if n<0 then a:=a*n;
until n=0;
Writeln(Сумма положительных чисел: ,b);
Writeln(Произведение отрицательных чисел: ,a);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку