Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)
program P1;
uses
crt;
var
mas : array[1..100] of integer;
i,ms,summ : integer;
begin
clrscr;
writeln(Vvod massiva: );
ms := 1;
repeat
read(mas[ms]);
inc(ms);
until
mas[ms-1] = 0;
summ := 0;
for i := 1 to ms-1 do
summ := summ + mas[i];
writeln(Resultat: ,summ);
readln;
readln;
end.
Оцени ответ
