С начала дня прошло n секунд,определить что в данный момент показывают электронные часы.
Помогите составить программу в Паскале

//PascalABC.Net
var
  n:longint;
  s,m,h:integer;
  ss,mm,hh:string;
begin
  Write(Целое число секунд: ); Read(n);
  h:=n div 3600; n:=n mod 3600;
  m:=n div 60; s:=n mod 60;
  Str(s,ss); if length(ss)=1 then ss:=0+ss;
  Str(m,mm); if length(mm)=1 then mm:=0+mm;
  Str(h,hh); if length(hh)=1 then hh:=0+hh;
  Writeln(hh+:+mm+:+ss)
end.

Тестовое решение:
Целое число секунд: 31415
08:43:35

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку