Дано сначала число n, а затем n натуральных чисел, не превосходящих 100. Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.
ВХОДНЫЕ ДАННЫЕ
В первой строке вводится одно число n — натуральное, не превосходящее 10000.
Во второй строке вводятся n натуральных чисел, не превосходящих 100.
ВЫХОДНЫЕ ДАННЫЕ
Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Pascal ABC.net
Var A:array[1..100]of byte;
B:array[1..100]of integer;
N,i:integer;
Begin
Read(N);
For i:= 1 to N do
Begin
Read(A[i]);
B[A[i]]:=B[A[i]]+1;
End;
For i:= 1 to 100 do
if B[i]=1 then  Write(i, )
End.

Чтоб каждое число в своей строке выводилось, замени Write(i, ) на WriteLn(i)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку