Помогите с программой в паскале!
На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т. д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
ВХОДНЫЕ ДАННЫЕ
Дана последовательность цифр от 1 до 9, заканчивающаяся нулем.
ВЫХОДНЫЕ ДАННЫЕ
Выведите через пробел количество единиц, двоек, …, девяток в этой последовательности.
ПРИМЕРЫ
ВВОД ВЫВОД
1 1 4 1 5 8 6 3 5 1 0
4 0 1 1 2 1 0 1 0
Var a: array [1..9] of word;
i: longint;
begin
for i := 1 to 9 do a[i] := 0;
repeat
read(i);
if i <> 0 then inc(a[i])
until i = 0;
for i := 1 to 9 do write(a[i], )
end.
Оцени ответ
