Составьте программу, которая по введенному k – числу цветков печатает фразу «В букете k цветков», причем согласовывает окончание слова «цветок» с числом k. НА ПАСКАЛЕ

Через Case :
Var
k:integer;
Begin
WriteLn(Введи число k);
ReadLn(k);
if k in[11..19] then WriteLn(В букете ,k, цветков)
else
Case k mod 10 of
1:WriteLn(В букете ,k, цветок);
2..4:WriteLn(В букете ,k, цветка);
0,5..9:WriteLn(В букете ,k, цветков);
end
End.

Через if :

Var
k:integer;
Begin
WriteLn(Введи число k);
ReadLn(k);
if k in[11..19] then WriteLn(В букете ,k, цветков)
else
Begin
if k=1 then WriteLn(В букете ,k, цветок);
if k mod 10 in[2..4] then WriteLn(В букете ,k, цветка);
if (k mod 10 in[5..9])or(k=0) then WriteLn(В букете ,k, цветков);
end
End.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку